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Dear customers!
We strongly recommend to read this documentation attentively to save your time during further setting up of our theme.

General Information

Dear customers, we appreciate that you have chosen our theme! XStore - is an elegant and neat theme outside, at the same time with a powerful admin module inside. All the
8theme software products are developed with quality and distinguished not only by programming level but also by the eﬀective teamwork of customer support in the process
of theme using. Before theme installation and its use, we recommend ﬁrstly to examine the documentation in details, watch the video tutorials and look through the forum
topics according to the questions you`re interested in.

1.1. XStore Theme Requirements
Before using XStore theme you need to be sure that your server and WordPress meets theme requirements. Theme requires at least WordPress version 3.9+. Such problems
as white screen after theme installation, out of memory errors, fails when import demo content etc, as a rule, are related to server settings and low PHP conﬁguration limits.
Change them by yourself or contact your hosting provider and ask to increase limits to a minimum as follow:
ﬁle_get_contents() function should be enabled in the server conﬁguration;
PHP version: 5.3 or higher;
max_execution_time: no less than 180;
memory_limit: no less than 128M;
upload_max_ﬁlesize: no less than 40M.
Use WordPress phpinfo plugin (https://wordpress.org/plugins/wordpress-php-info/) to check your PHP conﬁguration limits.

1.2. Support
Due to Envato Item Support Policy (http://themeforest.net/page/item_support_policy), we provide theme support for 6 months from the purchase date. It means during those 6
months we aim to help our clients if they need additional information about the theme's options and features or have any unresolved diﬃculties with the template. For this
reason, the support team is at your service. But we are not able to provide support for code customization or third-party plugins! If you need advice about anything other than
minor template customization, want to implement new functions or make the theme compatible with third-party plugins we recommend to request developer help. Also, you’ll
have the option to purchase extended item support, increasing the item support period up to a maximum of 12 months from the date of purchase. You can ﬁnd detailed
information on ThemeForest (http://themeforest.net/page/item_support_policy).
To be helpful we prefer you contact us on Support Forum (http://www.8theme.com/forums/):
Create an account or login to existing one;
Be sure you added theme purchase code on My Account page (http://www.8theme.com/my-account/) (information about what purchase code is and where to get it read
here (http://www.8theme.com/blog/purchase-code-where-to-download/)). Theme support is oﬀered to veriﬁed customers only.
Navigate to theme forum and press Create Topic button.

We would be very grateful if you use ThemeForest comments for presale requests only or questions that are not related to support. If you have a critical problem and really
need to give us access to your account you can contact us by using a contact form on our proﬁle`s page on Themeforest http://themeforest.net/user/8theme
(http://themeforest.net/user/8theme) - at the bottom of the right sidebar.

Installation & Upgrade

2.1. Theme Package
After theme purchase, please, download the theme from ThemeForest. For that, you need to enter Downloads area in your account on ThemeForest, where you will see all your
purchased themes. Find XStore template among them and click on the Download button on the right from the main content. In the provided list you will see the opportunity to
download the whole theme package with all additional ﬁles or the theme .zip ﬁle directly.
If you have downloaded the whole theme package, you will ﬁnd there the following ﬁles after extracting:

XStore_Theme_v.x.x.zip ﬁle which is the WordPress theme
Translation ﬁles folder
Documentation folder
PSD folder
Files for import
xstore-child theme folder

2.2. Theme Installation
Watch our video tutorial how to install theme

(https://www.youtube.com/watch?v=bHE_UhSJM10)

You can install the theme in two ways.

Method 1 – WordPress admin dashboard
Navigate to Appearance > Themes > Add New.
Choose XStore_Theme_v.x.x.zip ﬁle. Press the Install Now button to upload and install the theme

Method 2 – FTP

Method 2 – FTP
Connect to your server via FTP software.
Extract XStore_Theme_v.x.x.zip ﬁle and upload only extracted xstore folder to /wp-content/themes/ folder on your server.
Navigate to Appearance > Themes and activate xstore theme.

If you get an error: Are you sure you want to do this? This usually occurs when either the PHP memory limit or max post size for WordPress has been reached. Read 1.1. xstore
Theme Requirements. The easiest workaround for this is to install theme through FTP (see above). Alternatively, you'll need to change a number of settings either on
WordPress or on your web host.

Included plugins
XStore theme includes a number of perfect plugins that greatly increase the theme opportunities and open new horizons.The installation of plugins will be required once after
the theme activation.
Install and Activate them. In case if automatic plugin installation fails (as a rule it is because of your server settings), you can install them manually via your Dashboard: Plugins
> Add New > Upload Plugin > Browse plugins archives. Or via FTP, by uploading and extracting the plugin zip ﬁles into wp-content/plugins folder. You can ﬁnd the zip ﬁles for
plugin installation in the theme folder xstore/theme/plugins. Detailed information about plugins you can ﬁnd in item 3. Plugins of this documentation.

2.3. Theme Upgrade
Nothing stands still, the updates for WP and plugins are constantly released and they are included in our template. We supplement our theme with new features and ﬁx all the
issues. Because of this our team regularly updates theme. We recommend you always to use the last theme version to avoid the issues with incorrect template functioning.
While the theme update the theme ﬁles will be rewritten and if you made any changes directly in them, these changes will be lost. So, if you are planning to customize your
template, we insistently advise you to use Child Theme or Custom CSS area in Theme Options in case your changes aﬀect only CSS styles. The theme update aﬀects only the
theme ﬁles and does not inﬂuence the database. But, to avoid any diﬃculties, please, do the backup of theme ﬁles and database before any update.

Follow the steps below to update theme through FTP:
1.
2.
3.
4.

Download the zipped package from ThemeForest and extract to your desktop.
In the extracted package you will ﬁnd archive XStore_Theme_v.x.x.zip, which is the WordPress theme.
Extract zip ﬁle and upload only extracted xstore folder to /wp-content/themes/ folder on your server with overwriting.
Check if you use the latest version of XStore Core plugin. Update, also, this plugin if your version is not up to date.

Update using Envato Market (Automatic Updates)
Envato Market is a plugin for automatic WordPress theme updates that provides fast, eﬃcient updates to keep your theme bug free and compatible with the latest version of
WordPress. Visit the Envato Market Github page (http://envato.github.io/wp-envato-market/) to download the plugin zip ﬁle.
1. Before you install the plugin, you should request your Envato API token (https://build.envato.com/create-token/?purchase:download=t&purchase:verify=t&purchase:list=t).
2. Install and activate it like any other plugin. A new menu item, “Envato Market,” will appear in the admin sidebar. Click on the sidebar link and enter your marketplace
username and secret Envato API Personal Token. Click “Save Settings.” All of your theme purchases will now appear on this page after it refreshes.
3. The plugin will now alert you to theme updates – so long as you check the toolkit settings regularly. Click on “install automatically” beside of your theme to automatically
update them.

Update using Easy Theme Update plugin
You may also use Easy Theme Update plugin (http://wordpress.org/extend/plugins/easy-theme-and-plugin-upgrades/) to backup your theme and upload the new version.
Please, re-save your XStore options after upgrading the theme. Navigate to admin panel > Theme Options and hit Save changes.

2.4. Demo Content

To make settings up your site easy and faster you may import demo content. There are two ways you can import xstore Theme Demo Content:
One-click installation
Default import of .xml ﬁles

One Click Installation
This way allows you to import pages, posts, projects, slider, simple menu, theme versions or additional pages from our demos. You need to import Base demo content ﬁrst
before proceeding to theme versions import. To import our demo content follow the steps below:
Install and activate required and recommended plugins before you proceed.
Go to Theme Options > Import/Export > Dummy Content and select Base content to import posts, projects, products and simple menu. Press install Base Content button.
Wait a moment when you’ll see Success message and install version you like.
Now you may regenerate demo images into the appropriate sizes for various areas. Install Regenerate Thumbnails plugin (https://wordpress.org/plugins/regeneratethumbnails/), navigate to Tools > Regenerate Thumbnails tab and Regenerate All Thumbnails. It can take a few minutes depending on server speed and number of images
you have.

.XML ﬁles import
If you don't want to import all of our dummy content or just need separate pages from our demo, also if you can't use one click import according to server settings Import of
.XML ﬁles is your way. We included all the demo versions and additional pages import to XML Files folder of theme package. There you'll be able to see theme .xml ﬁles,
Revolution slider archive ﬁles. xstore Theme Options can also be imported by copying the text ﬁle and pasting its content into the Import from ﬁle ﬁeld on the Import/Export
tab in xstore Theme Options.

Important: Images you get after demo content import can neither be used on a live site nor redistributed. If you want to ﬁnd out where images came from to buy the license
use image search engine https://www.tineye.com/ (https://www.tineye.com/).

Plugins

3.1. General Info
First of all, we would like to specify that we do not guarantee the compatibility of our theme with all the third-party plugins for WordPress. Our template is fully compatible only
with the plugins that are included in our theme and also WPML plugin. You often (not always) need to customize the extension to make it work properly with your theme. It's
impossible for theme author to make the theme compatible with all existing extensions. Please, take that into your consideration and treat with understanding!

3.2. Included plugins
XStore theme includes the following plugins:

Required plugins
XStore Core - plugin that includes additional functionality of XStore theme (Portfolio, Testimonials, Static Blocks etc).
Custom Metaboxes and Fields for WordPress - plugin that enables 8theme Layout Options for Pages, Posts.
Redux Framework - plugin that enables Theme Options module.
Revolution Slider (https://revolution.themepunch.com/) - plugin to create awesome sliders.
WPBakery Visual Composer (http://vc.wpbakery.com/) - page builder.
WooCommerce - for selling online.

Recommended plugins
Contact Form
GMAPS for VC (http://workingwithpixels.com/gmaps-for-visual-composer)
Cookie Notice
MailChimp
Wishlist
As we are not developers of all these plugins, you may ﬁnd on their developers’ websites all the setup information and documentation for them.

3.3. Update
Plugins authors regularly release the updates and in order to use all the features or ﬁx already found issues, we recommend you to follow the plugins versions and update them
on your installations. To update the plugins, switch to your server with FTP. Copy extracted plugins folders into wp-content/plugins/ folder

3.4. Activation and Purchase Codes
All the plugins included in our theme are external and we have the right to build them into our theme as we purchase the Extended License for each of these plugins. The
plugins run perfectly and are fully functional. Keep in mind, we are constantly including the plugin updated versions and while every theme update you may ﬁnd the actual
plugin version in the theme folder. There is no doubt that you can get the current plugin version directly from us. For that, it will be enough to login to your account on our site (
http://www.8theme.com/my-account/ (http://www.8theme.com/my-account/) ), then go to http://www.8theme.com/download-plugins/ (http://www.8theme.com/downloadplugins/) page, enter your purchase code and you'll get access to all necessary archives. These plugins registration is not obligatory! The plugins are functioning perfectly
without any activation. The plugin activation option was added in the plugin only for the customers to get automatic updates and support directly from plugin developers. Only
in case you need this features, you will need to purchase and register the plugin. This is not only our practice but all the theme authors from ThemeForest.

Theme Settings

XStore theme is managed through settings called 8Theme Options and 8theme Page Layout. 8Theme Options are located in Dashboard > 8theme Options and contain settings
organized into logical tabbed sections. These are global options for your website. If you want to set speciﬁc options for a particular page, post or product set them in 8theme
Layout settings, which have a higher priority and are located in every page/post/product.

4.1. General Theme Options
General - You can set up some general options for your site in this section. Includes: Layout, Header Type, Header Settings, Breadcrumbs, Footer, 404 Page, Facebook Login,
Share buttons settings.
Styling – These options allow you to set custom colors for all the elements around the site. Includes: Content, Navigation, Footer, Copyrights, Custom CSS settings.

Typography – You can set up fonts for your website.
E-Commerce – Here you can ﬁnd all the e-commerce settings of our theme. Includes: Shop, Categories, Product Page Layout, Single Product Page, Quick View, Promo
Popup

Blog and Portfolio – You can set up options related to blog and portfolio in this section. Includes: Blog Layout, Single Post, Portfolio settings.
Import/Export – This section allows to install Dummy content or move settings from theme options between themes or when you move your website from the test site to live.
Includes: Dummy Content, Import/Export of Theme Options.

4.2. 8theme Page/Post Layout settings, 8theme Post Options
8theme Page/Post Layout settings

Custom logo for this page/post – You can upload the custom logo that will be visible on this page/post only.
Sidebar Position – Select position of sidebar if you need it diﬀerent from selected in global 8Theme Options.
Widget Area – Allows you to choose what widget area you want to display. You may use even the custom one.
Sidebar width – Set width of the sidebar on this page/post.
Custom navigation for this page/post – If you want to use the navigation diﬀerent from the main one use this option.
One page navigation for this page/post – If you want to use one-page navigation to scroll by section use this option.
Breadcrumbs Style – If you need to use breadcrumbs type diﬀerent from the global one this option is for you. Use Featured image to upload breadcrumbs background (for
page only).
Breadcrumbs Eﬀect – If you need to use breadcrumbs eﬀect diﬀerent from the global one this option is for you.
Page slider – Allows you to use full width slider instead of page heading.
Use custom footer for this page/post – This option allows you to select custom footer for this page. Use Static Block to create the custom footer.
Custom background image – Allows you to use the background image.
Custom background color – Allows you to set the background color.

8theme Post Options
Also, there are some options available for posts only.

Post template – Select size and position of featured image;
Hide featured image on single - check this option in case you need to hide featured image for some post only;
Hide share buttons - check this option in case you need to hide share buttons for this post only;
Post featured video (for video post format) - use to show video instead of featured image on single post page if Video post format is selected;
Soundcloud audio shortcode (for audio post format) - use to show audio instead of featured image on single post page if Audio post format is selected;
Quote (for quote post format) - use to show quote with featured image if Quote post format is selected;
Primary category - if the posts have multiple categories, the one selected will show up in blocks.

8theme Product Options
Detailed information about XStore product options you can ﬁnd in 8. E-Commerce item of this documentation.

4.3. XStore Shortcodes
There are several shortcodes which can be used in xstore theme inside posts and pages.
[alert] insert the alert block with custom title and message;
[base_url] the path for WordPress folder;
[block id= " "] inserts statick block;
[blockquote] inserts the blockquote;
[button] inserts the button;
[dropcap] inserts dropcap;
[googlechart] inserts chart with assigned attributes;
[googlefont] shortcode to set google font for headings;
[checklist] inserts the unordered list. Should be used together in a speciﬁc order;
[portfolio] inserts Recent Projects slider;
[qrcode] inserts the qrcode;
[share] inserts social icons (facebook, twitter, mail, pinterest, google+);
[template_url] the path for template folder;
[toggle_block][toggle]shortcodes to create block with toggles. Should be used together in a speciﬁc order;
Also, you can use visual editor

4.4. Static Blocks
Static blocks is a great theme feature that makes adding content to your site easy and convenient. Static blocks allow you to add additional content for product, create footer
layout, facilitate creation of promo popup etc. Static blocks can be used anywhere on your site to display text, images, sliders, widgetised sidebars etc. Go to Dashboard >
Static Block > Add new and you'll be able to compose block layout in no time.
Important: If you want to use Visual Composer to build block layout don't forget to select it in Visual Composer settings.

If you want to display static block using shortcode you will need Static Block ID. You can ﬁnd it in the url of your static block while edit it. See image below

4.5. Widgets & Custom Widget Areas
There are 17 default widget areas, which you can use to add your own content and functionality (Appearance > Widgets):
Main sidebar - Default sidebar of all the pages and posts.
Left side top bar area - Sidebar that appears at the left side of the top bar. You can use it for language switcher as well as for share buttons or tel number.
Right side top bar area - Sidebar that appears at the right side of the top bar. You can use it for language switcher as well as for share buttons or tel number.
Mobile side top bar area - Sidebar that appears on mobile devices only when you click on the main menu.
Top panel - Sidebar that appears at the top of the site. You can use it to add additional information about your store or other.

Shop sidebar - Sidebar that appears on Shop page
Filters area - Area that appears on Shop page, above the products. Is hidden by default and could be opened if you click Filter button.
After products - Area that appears on Shop page below the products.

Single Product Page sidebar - Sidebar that appears on Single Product Page.
Cart area - Additional area that appears on Cart page before Coupon Code. Could be used for advert.
PreFooter - Add the content you want to display in prefooter. We recommend to use Static Block feature and Static Block Widget to build multicolumn layout.
Footer Columns, Footer Copyrights - Add the content you want to display in footer.

You can create additional sidebars to add your own content and functionality and to use diﬀerent sidebars on diﬀerent pages/posts. Navigate to Appearance > Widgets. Fill in
Custom Sidebar title and press Add Sidebar button.
Place necessary widgets into newly created sidebar. Then create page (Pages > Add New) and on the right side of the 8theme Layout Options choose Sidebar Position,
necessary Sidebar Width and desired Widget Area.

Pages

Pages are almost the main element while creating the site. They are intended for static content, that's why pages are a good way to publish information that doesn't change
much. You can create any number of pages with content. XStore theme includes 2 additional page layouts - Blank Page and Portfolio - to create speciﬁc pages.

5.1. New Page
To get started adding a new page to your site navigate to Dashboard > Pages > Add new. Add the title of the page. If you have pretty permalinks set up, the title of your page
will also be the URL slug. Next, add some content. We recommend using Visual Composer editor if you want to add something more than just a simple text content. The
8theme Layout Options section allows you to set speciﬁc options to make your page look in the best way. Detailed information you can ﬁnd in 4.2. 8theme Layout settings.
Preview the page one last time, then click Publish. You’ve added a new page to your WordPress site.

5.2. Contact Page
If you want to receive feedback from your visitors, having a Contact Us page on your site is an easy way to achieve that. Go to Pages > Add new and create a page called
"Contact Us" (or whatever you want your contacts page called). To add contact form use Contact Form 7 plugin (https://wordpress.org/plugins/contact-form-7/).

5.3. Portfolio Page
You may also use our theme as a Portfolio. It is the perfect way to share your artwork, photography, or anything visual you want to show oﬀ. Create Portfolio Page and set the
page template (under Page Attributes) to Portfolio. It will be the main page with all your projects. Then go to 8Theme Options > Blog & Portfolio > Portfolio and set necessary
options. You may create New Projects at Portfolio > Add New.

5.4. Blank Page
XStore includes Blank Page template that allows you to build pages without showing the header or footer. They are perfect to create a landing page design or for such pages
like "Maintenance Mode" or "Coming Soon". You can use all the same page options and the element for content.

5.5. Blog Page
By default, WordPress displays your content in a blog format on the homepage. But if you want to create a separate page for blog posts just fo the following:
Navigate to Pages > Add New. You can title this page as Blog.
Then go to Settings > Reading and under the Front page displays option choose A static page.
Below that choose the page to be used as the front page and the page for your blog posts. Save your changes, and load your site to review them.

Menu

6.1. General Information
XStore supports custom WordPress menu. Custom menus may contain links to pages, categories, custom links or other content types. If you want to add special things to the
menu like posts and posts categories, portfolio categories, classes for links, etc then please click on Screen options button in the right top corner where you'll be able to
choose much more options that can be used for menu items.
There is no limit in our theme on how many menus you can create. XStore theme includes 2 menu location: main and mobile menu. In section Theme Locations you can
choose which custom menu to associate with each location.
To create new menu navigate to Dashboard > Appearance > Menus page and press on create a new menu link. Now you can add Pages, Posts and Custom Links from blocks
located on the left. When you have your menu items arranged in order click on Save Menu.

XStore Menu Options
XSore theme has a number of additional settings to create the menu. Options change depending on menu item level.
Disable navigation labels - allows you disable menu titles (1st, 2nd levels).
Design - allows you to choose menu type (1st level) or set custom link item like image column (2nd, 3rd levels).
Columns - set number of columns if Mega Menu design type is selected (1st level).
Column width - you may control the width of every column inside Mega Menu by entering a percentage. 100% is equivalent to the sum of default column values (1 column
- 185px) that you set in Column;
Widget area - you may use widget area with custom content.
Icon name - each menu item can have a font awesome icon (http://fortawesome.github.io/Font-Awesome/icons/). Use font awesome class in the name. Ex: fa faconnectdevelop.
Label - you can apply the label for your menu item: new, sale, hot.
Menu item image - if you want to use the image for menu just upload image ﬁle and set menu position. You can use image like background for the menu item or like
separate image column.
Important note: you need to save menu after adding menu items to display the theme settings for the menu!

6.2. Mega Menu
Mega Menu is one of menu types of XStore theme.

Multi-column layout with image

Create general menu structure and save it.

For the ﬁrst level select:
Design type - MegaMenu, Columns - 4.

For the image item select:
Disable navigation label, Design - Image, Upload menu item image.

To create last row ( shipping information ) navigate to Static Blocks > create Static Block with 3 columns layout and use Icon, Text VC elements. You may change margins,
paddings, add background color if you need. After that go to Appearance > Widgets and create Custom Widget area. Add 8theme - Static Block widget and choose static
block area you just created. Go to Appearance > Menus and in last custom link item set the following options: Disable navigation label, Column width - 100%, Widget area choose your menu custom widget area.
Save and check the frontend.

Multi-column layout with multi-images

Create general menu structure and save it.

For the ﬁrst level select:
Design type - MegaMenu, Columns - 4.

For the image item select:
Disable navigation label, Design - Image without spacing, Upload image.

Subcategories with posts

Add Posts Category that has subcategories and save manu. For this item select: Design - Subcategories + Posts.

Slider

Theme supports Revolution (http://themepunch.com/revolution/) Slider, the installation of which would be provided for you after theme activation. After that, you may create
the sliders and use them on the site according to the plugin documentation. Documentation from the authors of the slider you can ﬁnd here
(http://www.themepunch.com/revslider-doc/slider-revolution-documentation/). Please, refer to it for further information about slider settings. Sliders can be added to any page.
To setup Revolution Slider, please, follow the next steps:
1. If you already have import ﬁle you may import the archives. Examples of sliders you can ﬁnd in XML ﬁles folder.
Navigate to Revolution Slider.
Press on Import Slider.
Upload an archive and press Import Slider button.
2. If you want to create new slider navigate to Revolution Slider > New Slider.
After that, you will reach a form where you are prompted to enter the Sliders Basic Settings.
The next step is creating/editing slides. Insert the slider content.
Include the Slider in our theme: from the widgets panel (drag the "Revolution Slider" widget to the desired sidebar) or from the post editor (insert the shortcode from
the sliders table) or add RevolutionSlider element if you build your page using Visual Composer.

E-Commerce

XStore is compatible with WooCommerce and includes design integration as well as custom shortcodes. WooCommerce is external plugin and theme documentation includes
only basic information to get started. Below you can ﬁnd links that have additional information about using WooCommerce.
WooCommerce Plugin Page (http://www.woothemes.com/woocommerce/) – oﬃcial WooCommerce plugin page.
WooCommerce Documentation (http://docs.woothemes.com/documentation/plugins/woocommerce/woocommerce-user-guide/getting-started/) – WooCommerce Online
documentation created by WooThemes
WooComerce Forums (http://wordpress.org/support/plugin/woocommerce) – the community forum for WooCommerce plugin created by WooThemes
WooComerce Shortcodes (http://docs.woothemes.com/document/woocommerce-shortcodes/) – shortcodes for WooCommerce, theme custom shortcodes are not
included in this.

Translation

10.1. Base theme translation
Using PoEdit
The translation ﬁle default.pot you can ﬁnd in Translation Files folder in theme package. Edit the .po ﬁle using POEdit (http://www.poedit.net/), use the translation ﬁeld to make
replacements. Read here (http://betterwp.net/wordpress-tips/create-pot-ﬁle-using-poedit./) how to do it right.
From the ﬁle menu, save ﬁle with your language name e.g de_DE.po. It will generate both a .po and .mo ﬁles for your translation. Place these ﬁles into languages folder /wpcontent/themes/xstore/languages.

Using Loco Translate plugin
Go to Plugins > Add new > install and activate Loco Translate plugin (https://wordpress.org/plugins/loco-translate/)
Go to Loco Translate > Themes > select XStore theme. Press "Add new language". Translate strings and Save.

In case you already have translation ﬁles place them in wp-content/languages/themes/ folder. Use xstore preﬁx, for example xstore-es_ES.po.

10.2. Translation with WPML
General setup
XStore is WPML compatible theme that means you may translate template to the language you need. To start you need to purchase a recent version of WPML
(http://wpml.org/purchase/), including the String Translation and Translation Management modules.
Follow Getting Started Guide (http://wpml.org/documentation/getting-started-guide/) after core WPML plugins installation.
To begin translation go to WPML > Theme and Plugin Localization. Click on Scan the theme for strings and you will see theme strings and which ones are translated or not.
Then select WPML > String translation and a list of the strings in the theme will be available. Choose the string you need to translate and press translation link to add
translations to languages.

Translating Projects, Skills, and Testimonials
To translate the custom post types and taxonomies (static blocks, projects, testimonials), go to WPML > Translation Management. Select Multilingual Content Management.

Navigate to Custom Posts where you can choose the translations for Projects, Static Blocks, Testimonials.
Navigate to Custom taxonomies below, you'll be able to choose the translations for Brands and Portfolio Categories.

Child Theme

XStore fully supports Child Theme.
A WordPress child theme is a theme that inherits the functionality of the parent theme. With child theme, you can make the modiﬁcation or add additional functionality to the
parent theme. A child theme is a safest and easiest way to modify an existing theme, whether you want to make a few tiny changes or extensive changes.
We have already created and included child theme in theme package. You just need to ﬁnd xstore-child folder in theme package and upload it to /wp-content/themes/ folder.
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